NetSight
high7.5

CVE-2025-61594

URI Credential Leakage Bypass over CVE-2025-27221

Impact

### Impact In affected URI version, a bypass exists for the fix to CVE-2025-27221 that can expose user credentials. When using the `+` operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. The vulnerability affects the `uri` gem bundled with the following Ruby series: * 0.12.4 and earlier (bundled in Ruby 3.2 series) * 0.13.2 and earlier (bundled in Ruby 3.3 series) * 1.0.3 and earlier (bundled in Ruby 3.4 series) ### Patches Upgrade to 0.12.5, 0.13.3 or 1.0.4 ### References * https://www.ruby-lang.org/en/news/2025/02/26/security-advisories/ * https://hackerone.com/reports/2957667

Affected packages

EcosystemPackageAffectedFixed in
rubygemsuri< 0.12.50.12.5

Affected products

VendorProductAffected versions
Ruby-LangUri
before 0.12.5
from 0.13.0 before 0.13.3
from 1.0.0 before 1.0.4

Weakness classification

References