NetSight
critical9.8

CVE-2025-61622

Apache Pyfory python is vulnerable to deserialization of untrusted data

Impact

Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution. Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
pippyfory>= 0.12.0, < 0.12.30.12.3
pippyfury>= 0.1.0, <= 0.10.3none recorded

Affected products

VendorProductAffected versions
ApacheFory
from 0.1.0 through 0.10.3
from 0.12.0 through 0.12.2

Weakness classification

References