high7.5
CVE-2025-61733
Apache Kylin Authentication Bypass Vulnerability
Impact
Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. Users are recommended to upgrade to version 5.0.3, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.kylin:kylin | >= 4.0.0, < 5.0.3 | 5.0.3 |
| maven | org.apache.kylin:kylin-core-common | >= 4.0.0, < 5.0.3 | 5.0.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Kylin | from 4.0.0 before 5.0.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/8wmcffly6gp50nmfw8j4w3hlmv843yo0
- http://www.openwall.com/lists/oss-security/2025/09/30/7
- https://github.com/advisories/GHSA-mr9j-4j48-xcm2
- https://nvd.nist.gov/vuln/detail/CVE-2025-61733
- https://github.com/apache/kylin/pull/2336
- https://github.com/apache/kylin/commit/8b2cb8c71bd9885d70dad4f1a9822e38d9949b8c
- https://issues.apache.org/jira/browse/KYLIN-6081