NetSight
high7.3

CVE-2025-61735

Apache Kylin Server-Side Request Forgery (SSRF) Vulnerability

Impact

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected. Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.kylin:kylin>= 4.0.0, < 5.0.35.0.3
mavenorg.apache.kylin:kylin-common-server>= 4.0.0, < 5.0.35.0.3
mavenorg.apache.kylin:kylin-common-service>= 4.0.0, < 5.0.35.0.3
mavenorg.apache.kylin:kylin-core-common>= 4.0.0, < 5.0.35.0.3
mavenorg.apache.kylin:kylin-core-metadata>= 4.0.0, < 5.0.35.0.3
mavenorg.apache.kylin:kylin-ops-server>= 4.0.0, < 5.0.35.0.3
mavenorg.apache.kylin:kylin-server>= 4.0.0, < 5.0.35.0.3

Affected products

VendorProductAffected versions
ApacheKylin
from 4.0.0 before 5.0.3

Weakness classification

References