high7.5
CVE-2025-6209
LlamaIndex vulnerable to Path Traversal attack through its encode_image function
Impact
A path traversal vulnerability exists in run-llama/llama_index versions 0.11.23 through 0.12.40, specifically within the `encode_image` function in `generic_utils.py`. This vulnerability allows an attacker to manipulate the `image_path` input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files outside the intended directory. The vulnerability is fixed in version 0.12.41.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | llama-index-core | >= 0.11.23, < 0.12.41 | 0.12.41 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Llamaindex | Llamaindex | from 0.12.27 before 0.12.41 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/run-llama/llama_index/commit/cdeaab91a204d1c3527f177dac37390327aef274
- https://huntr.com/bounties/e89d14f8-bfe8-4c9a-bb2a-656c01cc9a68
- https://github.com/advisories/GHSA-2rhq-96q8-4vjq
- https://nvd.nist.gov/vuln/detail/CVE-2025-6209
- https://github.com/pypa/advisory-database/tree/main/vulns/llama-index/PYSEC-2025-65.yaml