medium5.4
CVE-2025-62198
Apache Atlas UI: Authenticated User XSS
Impact
An authenticated user can perform XSS. This issue affects Apache Atlas versions 2.4.0 and earlier. Users are recommended to upgrade to version 2.5.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.atlas:atlas-dashboardv2 | < 2.5.0 | 2.5.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Atlas | before 2.5.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-v73p-f52r-fmmr
- https://nvd.nist.gov/vuln/detail/CVE-2025-62198
- https://lists.apache.org/thread/nv893lhz3ok08f25j3v4z1to5nrpdp7k
- http://www.openwall.com/lists/oss-security/2026/06/20/1
- https://github.com/apache/atlas/commit/800f979307d6ea0f0b6563ec890f6b728022e497