NetSight
high8.8

CVE-2025-62228

Apache Flink CDC is vulnerable to SQL Injection through maliciously crafted identifiers

Impact

Apache Flink CDC version 3.0.0 to before 3.5.0 are vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, users are recommended to update Flink CDC version to 3.5.0 which address this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.flink:flink-cdc-pipeline-connectors>= 3.0.0, < 3.5.03.5.0
mavenorg.apache.flink:flink-connector-oracle-cdc>= 3.0.0, < 3.5.03.5.0
mavenorg.apache.flink:flink-connector-db2-cdc>= 3.0.0, < 3.5.03.5.0
mavenorg.apache.flink:flink-connector-sqlserver-cdc>= 3.0.0, < 3.5.03.5.0
mavenorg.apache.flink:flink-connector-mysql-cdc>= 3.0.0, < 3.5.03.5.0

Affected products

VendorProductAffected versions
ApacheFlink Cdc
Version 3.4.0

Weakness classification

References