medium4.8
CVE-2025-62265
Liferay Portal is vulnerable to XSS in the Blogs widget
Impact
Cross-site scripting (XSS) vulnerability in the Blogs widget in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.8, 7.4 GA through update 92, 7.3 GA through update 36, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via a crafted <iframe> injected into a blog entry's “Content” text field. The Blogs widget in Liferay DXP does not add the sandbox attribute to <iframe> elements, which allows remote attackers to access the parent page via scripts and links in the frame page.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | com.liferay.portal:release.portal.bom | >= 7.4.0-ga1, < 7.4.3.112-ga112 | 7.4.3.112-ga112 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Liferay | Digital Experience Platform | through 7.4 Versions 2023.q3.1, 2023.q3.2, 2023.q3.3, 2023.q3.4, 2023.q3.5 |
| Liferay | Liferay Portal | from 7.2.0 before 7.4.3.112 |