NetSight
critical6.3

CVE-2025-64408

Apache Causeway vulnerable to deserialization in Java

Impact

Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.  This issue affects all current versions. Users are recommended to upgrade to version 3.5.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.causeway.commons:causeway-commons< 3.5.03.5.0
mavenorg.apache.causeway.core:causeway-applib< 3.5.03.5.0
mavenorg.apache.causeway.core:causeway-core< 3.5.03.5.0
mavenorg.apache.causeway.viewer:causeway-viewer-wicket< 3.5.03.5.0

Affected products

VendorProductAffected versions
ApacheCauseway
from 2.0.0 before 3.5.0
Version 4.0.0

Weakness classification

References