high7.5
CVE-2025-64775
Apache Struts is Vulnerable to DoS via File Leak
Impact
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.struts:struts2-core | >= 6.0.0, < 6.8.0 | 6.8.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Struts | from 2.0.0 before 6.8.0 from 7.0.0 before 7.1.1 |