medium6.6
CVE-2025-65960
Contao is vulnerable to remote code execution in template closures
Impact
### Impact Backend users with precise control over the contents of template closures can execute arbitrary PHP functions that do not have required parameters. ### Patches Update to Contao 4.13.57, 5.3.42 or 5.6.5 ### Workarounds Manually patch the `Contao\Template::once()` method. ### Resources https://contao.org/en/security-advisories/remote-code-execution-in-template-closures
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | contao/core-bundle | >= 4.0.0, < 4.13.57 | 4.13.57 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Contao | Contao | from 4.0.0 before 4.13.57 from 5.0.0 before 5.3.42 from 5.4.0 before 5.6.5 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://contao.org/en/security-advisories/remote-code-execution-in-template-closures
- https://github.com/contao/contao/security/advisories/GHSA-98vj-mm79-v77r
- https://github.com/advisories/GHSA-98vj-mm79-v77r
- https://github.com/contao/contao/commit/577d7fdd5b1ca84f65f034ff556865422f0a3bd1
- https://github.com/contao/contao/commit/676f0855d39007ac9a0dbe7ae6a7414cba2312a5
- https://github.com/contao/contao/commit/ebf84c90e5679a67060f396b924ce4a3c3f206b3
- https://nvd.nist.gov/vuln/detail/CVE-2025-65960