NetSight
medium6.9

CVE-2025-66169

Apache Camel camel-neo4j component is vulnerable to cypher injection

Impact

Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.camel:camel-neo4j>= 4.10.0, < 4.10.84.10.8

Affected products

VendorProductAffected versions
ApacheCamel
from 4.10.0 before 4.10.8
from 4.14.0 before 4.14.3
from 4.15.0 before 4.17.0

Weakness classification

References