NetSight
high8.8

CVE-2025-66518

Apache Kyuubi Server vulnerable to Path Traversal

Impact

Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config. This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2. Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.kyuubi:kyuubi-server_2.12>= 1.6.0, < 1.10.31.10.3

Affected products

VendorProductAffected versions
ApacheKyuubi
from 1.6.0 before 1.10.3

Weakness classification

References