NetSight
medium4.3

CVE-2025-67746

Composer is vulnerable to ANSI sequence injection

Impact

### Impact Attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but Composer still published a CVE as it has potential for abuse, and Composer wants to be on the safe side informing users that they should upgrade. ### Patches 2.2.26 for 2.2 LTS or 2.9.3 for mainline.

Affected packages

EcosystemPackageAffectedFixed in
composercomposer/composer>= 2.0.0, < 2.2.262.2.26

Affected products

VendorProductAffected versions
GetcomposerComposer
from 2.0.0 before 2.2.26
from 2.3.0 before 2.9.3

Weakness classification

References