NetSight
medium6.8

CVE-2025-68129

Auth0-PHP SDK has Improper Audience Validation

Impact

### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Projects are affected if they meet the following preconditions: - Applications using the Auth0-PHP SDK, versions between v8.0.0 and v8.17.0, or - Applications using the following SDKs that rely on the Auth0-PHP SDK versions between v8.0.0 and v8.17.0: - a. Auth0/symfony, - b. Auth0/laravel-auth0, - c. Auth0/wordpress. ### Resolution Upgrade Auth0/Auth0-PHP to version 8.18.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.

Affected packages

EcosystemPackageAffectedFixed in
composerauth0/auth0-php>= 8.0.0, < 8.18.08.18.0

Affected products

VendorProductAffected versions
Auth0Auth0-Php
from 8.0.0 before 8.18.0
Auth0Laravel-Auth0
from 7.0.0 before 7.20.0
Auth0Symfony
from 5.0.0 before 5.6.0
Auth0Wp-Auth0
from 5.0.0 before 5.5.0

Weakness classification

References