critical9.8
CVE-2025-68615
net-snmp is a SNMP application library, tools and daemon.
Impact
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Net-Snmp | Net-Snmp | before 5.9.5 Version 5.10 |
| Debian | Debian Linux | Version 11.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/net-snmp/net-snmp/security/advisories/GHSA-4389-rwqf-q9gq
- http://www.openwall.com/lists/oss-security/2026/01/09/2
- https://lists.debian.org/debian-lts-announce/2026/01/msg00000.html
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-detection-script-buffer-overflow-vulnerability-affecting-net-snmp
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-mitigation-script-buffer-overflow-vulnerability-affecting-net-snmp