NetSight
high8.8

CVE-2025-69219

Apache Airflow Providers Http has Unsafe Pickle Deserializatio leading to RCE via HttpOperator

Impact

A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low. Users should upgrade to version 6.0.0 of the provider to avoid even that risk.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow-providers-http< 6.0.06.0.0

Affected products

VendorProductAffected versions
ApacheAirflow Providers Http
from 5.1.0 before 6.0.0

Weakness classification

References