medium5.4
CVE-2025-69289
Discourse is an open source discussion platform.
Impact
Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Discourse | Discourse | before 3.5.4 from 2025.11.0 before 2025.11.2 Versions 2025.12.0, 2026.1.0 |