NetSight
high9.8Public exploit code

CVE-2025-6965

SQLitePCLRaw.lib.e_sqlite3 has a vulnerable dependency on SQLite

Public exploit code

Working exploit or proof of concept code has been published for this vulnerability. Treat unpatched systems as at risk.

Impact

There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.

Affected packages

EcosystemPackageAffectedFixed in
nugetSQLitePCLRaw.lib.e_sqlite3<= 2.1.11none recorded
nugetSQLitePCLRaw.lib.e_sqlite3.android<= 2.1.11none recorded
nugetSQLitePCLRaw.lib.e_sqlite3.ios<= 2.1.11none recorded

Affected products

VendorProductAffected versions
SqliteSqlite
before 3.50.2
AppleIpados
before 26.0.0
AppleIphone Os
before 26.0.0
AppleMacos
before 26.0.0
AppleTvos
before 26.0.0
AppleVisionos
before 26.0.0
AppleWatchos
before 26.0.0
SiemensRuggedcom Crossbow
before 5.8
SiemensSidis Prime
before 4.0.800

Weakness classification

References