medium3.5
CVE-2025-7053
Cockpit - Content Platform vulnerable to XSS through name or email argument names
Impact
A vulnerability was found in Cockpit versions up to 2.11.3. This issue affects some unknown processing instances of the file /system/users/save. The manipulation of the arguments "name" or "email" leads to cross-site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 will address this issue. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted accordingly. A patch and new release were made available very quickly.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | cockpit-hq/cockpit | < 2.11.4 | 2.11.4 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Agentejo | Cockpit | through 2.11.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/Cockpit-HQ/Cockpit/commit/bdcd5e3bc651c0839c7eea807f3eb6af856dbc76
- https://github.com/Cockpit-HQ/Cockpit/releases/tag/2.11.4
- https://vuldb.com/?ctiid.314819
- https://vuldb.com/?id.314819
- https://vuldb.com/?submit.605594
- https://github.com/advisories/GHSA-j4rj-fgcq-wmqp
- https://nvd.nist.gov/vuln/detail/CVE-2025-7053