medium6.1
CVE-2025-70792
Microweber Cross-site Scripting vulnerability
Impact
There is a Cross-site Scripting vulnerability in the "/admin/category/create" endpoint of Microweber 2.0.19. An attacker can manipulate the "rel_id" parameter in a crafted URL and lure a user with admin privileges into visiting it, achieving JavaScript code execution in the victim's browser. The issue was reported to the developers and fixed in version 2.0.20.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | microweber/microweber | < 2.0.20 | 2.0.20 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Microweber | Microweber | Version 2.0.19 |