high7.5
CVE-2025-7338
Multer vulnerable to Denial of Service via unhandled exception from malformed request
Impact
### Impact A vulnerability in Multer versions >= 1.4.4-lts.1, < 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed request. This request causes an unhandled exception, leading to a crash of the process. ### Patches Users should upgrade to `2.0.2` ### Workarounds None
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | multer | >= 1.4.4-lts.1, < 2.0.2 | 2.0.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/multer/commit/adfeaf669f0e7fe953eab191a762164a452d143b
- https://github.com/expressjs/multer/security/advisories/GHSA-fjgf-rc76-4x9p
- https://github.com/advisories/GHSA-fjgf-rc76-4x9p
- https://nvd.nist.gov/vuln/detail/CVE-2025-7338