NetSight
low3.4

CVE-2025-7339

on-headers is vulnerable to http response header manipulation

Impact

### Impact A bug in on-headers versions `< 1.1.0` may result in response headers being inadvertently modified when an array is passed to `response.writeHead()` ### Patches Users should upgrade to `1.1.0` ### Workarounds Uses are encouraged to upgrade to `1.1.0`, but this issue can be worked around by passing an object to `response.writeHead()` rather than an array.

Affected packages

EcosystemPackageAffectedFixed in
npmon-headers< 1.1.01.1.0

Affected products

ProductAffected versions
On-Headers Versions `
before 1.1.0

Versions were read from the advisory text. No structured product data has been published for this record yet.

Weakness classification

References