NetSight
medium4.7

CVE-2025-9910

jsondiffpatch is vulnerable to Cross-site Scripting (XSS) via HtmlFormatter::nodeBegin

Impact

### Vulnerability in jsondiffpatch Versions of `jsondiffpatch` prior to `0.7.2` are vulnerable to Cross-site Scripting (XSS) in the `HtmlFormatter` (`HtmlFormatter::nodeBegin`). When diffs are rendered to HTML using the built-in formatter, untrusted payloads can inject scripts and execute in the context of a consuming web page. **Affected versions:** >= 0, < 0.7.2 **Patched version:** 0.7.2 **Remediation** Upgrade to `jsondiffpatch` `0.7.2` or later. The fix hardens the HTML formatter to avoid script injection. **Workarounds** Avoid using the HTML formatter on untrusted diffs, or sanitize/escape the rendered output.

Affected packages

EcosystemPackageAffectedFixed in
npmjsondiffpatch< 0.7.20.7.2

Affected products

ProductAffected versions
Package Jsondiffpatch
before 0.7.2

Versions were read from the advisory text. No structured product data has been published for this record yet.

Weakness classification

References