NetSight
medium6.1

CVE-2026-0540

DOMPurify contains a Cross-site Scripting vulnerability

Impact

DOMPurify 3.1.3 through 3.3.1 and 2.5.3 through 2.5.8, fixed in 2.5.9 and 3.3.2, contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting five missing rawtext elements (noscript, xmp, noembed, noframes, iframe) in the `SAFE_FOR_XML` regex. Attackers can include payloads like `</noscript><img src=x onerror=alert(1)>` in attribute values to execute JavaScript when sanitized output is placed inside these unprotected rawtext contexts.

Affected packages

EcosystemPackageAffectedFixed in
npmdompurify>= 3.1.3, <= 3.3.13.3.2

Affected products

VendorProductAffected versions
Cure53Dompurify
from 2.5.3 through 2.5.8
from 3.1.3 through 3.3.1

Weakness classification

References