low3.5
CVE-2026-0824
QuestDB UI's Web Console is Vulnerable to Cross-Site Scripting
Impact
A security flaw has been discovered in questdb ui up to 1.11.9. Impacted is an unknown function of the component Web Console. The manipulation results in cross site scripting. The attack can be executed remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 1.1.10 is recommended to address this issue. The patch is identified as b42fd9f18476d844ae181a10a249e003dafb823d. You should upgrade the affected component. The vendor confirmed early that the fix "is going to be released as a part of QuestDB 9.3.0" as well.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | @questdb/web-console | < 1.1.10 | 1.1.10 |
Affected products
| Product | Affected versions |
|---|---|
| Questdb Ui | before 1.11.9. |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/59lab/dbdb/blob/main/There%20is%20a%20cross-site%20scripting(XSS)%20vulnerability%20in%20the%20QuestDB%20database.md
- https://github.com/questdb/questdb/releases/tag/9.3.0
- https://github.com/questdb/ui/
- https://github.com/questdb/ui/commit/b42fd9f18476d844ae181a10a249e003dafb823d
- https://github.com/questdb/ui/pull/518
- https://github.com/questdb/ui/pull/519#issue-3790862030
- https://vuldb.com/?ctiid.340357
- https://vuldb.com/?id.340357
- https://vuldb.com/?submit.733253
- https://github.com/advisories/GHSA-xf94-h87h-g9wr
- https://nvd.nist.gov/vuln/detail/CVE-2026-0824