critical9.9
CVE-2026-102911
A flaw has been found in zosmaai pi-llm-wiki up to 0.11.7.
Impact
A flaw has been found in zosmaai pi-llm-wiki up to 0.11.7. Affected is an unknown function of the file mcp/index.ts of the component wiki_capture_source MCP tool. Executing a manipulation of the argument url can lead to os command injection. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 0.11.8 is able to address this issue. This patch is called 360867034e79175b45c8e04a98e4ca712bbaca35. Upgrading the affected component is advised.
Affected products
| Product | Affected versions |
|---|---|
| Zosmaai Pi-Llm-Wiki | before 0.11.7. |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/zosmaai/pi-llm-wiki/
- https://github.com/zosmaai/pi-llm-wiki/commit/360867034e79175b45c8e04a98e4ca712bbaca35
- https://github.com/zosmaai/pi-llm-wiki/issues/185
- https://github.com/zosmaai/pi-llm-wiki/pull/186
- https://github.com/zosmaai/pi-llm-wiki/releases/tag/v0.11.8
- https://vuldb.com/cve/CVE-2026-102911
- https://vuldb.com/submit/953898
- https://vuldb.com/vuln/411587
- https://vuldb.com/vuln/411587/cti