high7.3
CVE-2026-103552
Stack Overflow vulnerability in Apache Directory LDAP API.
Impact
Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache Directory LDAP API: From 1.2.0 | before 1.2.9. |
Versions were read from the advisory text. No structured product data has been published for this record yet.