NetSight
medium4.8

CVE-2026-106456

Backstage: Inconsistent credential enforcement for overlapping proxy routes

Impact

Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.

Affected packages

EcosystemPackageAffectedFixed in
npm@backstage/plugin-proxy-backend>= 0.5.0, < 0.6.180.6.18

Affected products

VendorProductAffected versions
LinuxfoundationBackstage\/Plugin-Proxy-Backend
from 0.5.0 before 0.6.18
LinuxfoundationBackstage
from 1.28.0 before 1.55.0

Weakness classification

References