NetSight
high8.5

CVE-2026-106459

Backstage: Improper input validation in Sentry scaffolder actions

Impact

Backstage is an open framework for building developer portals. From 0.3.0 until 0.3.8, the @backstage/plugin-scaffolder-backend-module-sentry package is affected by improper input validation in sentry scaffolder actions. An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. This issue is fixed in version 0.3.8.

Affected packages

EcosystemPackageAffectedFixed in
npm@backstage/plugin-scaffolder-backend-module-sentry>= 0.3.0, < 0.3.80.3.8

Affected products

VendorProductAffected versions
LinuxfoundationBackstage\/Plugin-Scaffolder-Backend-Module-Sentry
from 0.3.0 before 0.3.8
LinuxfoundationBackstage
from 1.47.0 before 1.54.8

Weakness classification

References