medium4.3
CVE-2026-108924
A vulnerability was identified in getkirby Kirby up to 4.9.5/5.5.3.
Impact
A vulnerability was identified in getkirby Kirby up to 4.9.5/5.5.3. Affected by this issue is the function OptionsQuery::resolve of the file src/Option/OptionsQuery.php of the component Dynamic Option Generation. The manipulation leads to authorization bypass. The attack is possible to be carried out remotely. Upgrading to version 4.9.6 and 5.6.0 can resolve this issue. You should upgrade the affected component.
Affected products
| Product | Affected versions |
|---|---|
| Getkirby Kirby | before 4.9.5 |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/getkirby/kirby/
- https://github.com/getkirby/kirby/releases/tag/4.9.6
- https://github.com/getkirby/kirby/security/advisories/GHSA-8r9g-hhm3-5jfh
- https://github.com/getkirby/kirby/security/advisories/GHSA-ch57-pqv8-vm6h
- https://vuldb.com/cve/CVE-2026-108924
- https://vuldb.com/submit/997196
- https://vuldb.com/vuln/416748
- https://vuldb.com/vuln/416748/cti