NetSight
medium6.3

CVE-2026-11440

A vulnerability was determined in theonedev onedev up to 15.0.5.

Impact

A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.

Affected products

ProductAffected versions
Theonedev Onedev
before 15.0.5.

Versions were read from the advisory text. No structured product data has been published for this record yet.

Weakness classification

References