high7.5
CVE-2026-115907
zip: legacy Shrink/Reduce/Implode decoder: denial of service from attacker-controlled ZIP64 uncompressed size
Impact
zip is a zip library for Rust that supports reading and writing simple ZIP files. From 5.1.0 until 9.0.0, applications built with the legacy-zip feature can reserve output capacity from an attacker-controlled ZIP64 uncompressed size before validating the compressed stream. The ShrinkDecoder path in src/legacy/shrink.rs can panic with a capacity overflow during ZipArchive::extract, and the Reduce and Implode decoders contain the same unbounded preallocation pattern. An unhandled panic can terminate an archive-processing service. This issue is fixed in version 9.0.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rust | zip | >= 5.1.0, < 9.0.0 | 9.0.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Zip-Rs | Zip2 | from 5.1.0, before 9.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-9hj8-73fh-9963
- https://github.com/zip-rs/zip2/security/advisories/GHSA-9hj8-73fh-9963
- https://nvd.nist.gov/vuln/detail/CVE-2026-115907
- https://github.com/zip-rs/zip2/pull/991
- https://github.com/zip-rs/zip2/commit/8b4991288b79ad11cce201c2d785d5baa795bd3e
- https://github.com/zip-rs/zip2/releases/tag/v9.0.0