high8.5
CVE-2026-116675
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
Impact
TinyMCE is an open source rich text editor. From 7.9.3 until 7.9.4 and from 8.5.1 until 8.9.3, the media plugin creates elements crafted through data-mce-object in the active document before sanitization. Those elements can execute malicious scripts during processing, resulting in stored cross-site scripting for users with the media plugin enabled. This issue is fixed in versions 8.9.3 and 7.9.4.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | tinymce | >= 8.5.1, < 8.9.3 | 8.9.3 |
| nuget | TinyMCE | >= 8.5.1, < 8.9.3 | 8.9.3 |
| composer | tinymce/tinymce | >= 8.5.1, < 8.9.3 | 8.9.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-mf2p-h6hf-fcwm
- https://github.com/tinymce/tinymce/security/advisories/GHSA-mf2p-h6hf-fcwm
- https://nvd.nist.gov/vuln/detail/CVE-2026-116675
- https://github.com/tinymce/tinymce/commit/bd1ab5ef024c648c3f9c0b409e54a6c227c7d8a2
- https://github.com/tinymce/tinymce/releases/tag/8.9.3
- https://www.tiny.cloud/docs/tinymce/7/7.9.4-release-notes/#overview
- https://www.tiny.cloud/docs/tinymce/latest/8.9.3-release-notes/#overview