CVE-2026-15007
A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user to cause service disruption by supplying a repo…
Impact
A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user to cause service disruption by supplying a repository release notes configuration file containing deeply nested YAML. When release notes were generated, the configuration file was parsed without a nesting depth limit, causing excessive resource consumption that could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.18, 3.18.12, 3.19.9, 3.20.5, and 3.21.3. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| GitHub | GitHub Enterprise Server | before 3.22 |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.18
- https://docs.github.com/en/enterprise-server@3.18/admin/release-notes#3.18.12
- https://docs.github.com/en/enterprise-server@3.19/admin/release-notes#3.19.9
- https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.5
- https://docs.github.com/en/enterprise-server@3.21/admin/release-notes#3.21.3