medium6.3
CVE-2026-15529
PyOD persistence.load deserializes untrusted artifacts before validation
Impact
A vulnerability was detected in yzhao062 pyod up to 3.6.1. Affected is the function pyod.utils.persistence.load of the file pyod/utils/persistence.py. Performing a manipulation of the argument path results in deserialization. The attack can be initiated remotely. Upgrading to version 3.6.2 is able to address this issue. It is recommended to apply a patch to fix this issue. The pull request to fix this issue requires some minor changes.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | pyod | >= 3.5.0, < 3.6.2 | 3.6.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-997v-r4v7-9f3g
- https://nvd.nist.gov/vuln/detail/CVE-2026-15529
- https://github.com/yzhao062/pyod/issues/697
- https://github.com/yzhao062/pyod/pull/698
- https://github.com/yzhao062/pyod
- https://vuldb.com/cve/CVE-2026-15529
- https://vuldb.com/submit/854559
- https://vuldb.com/vuln/377872
- https://vuldb.com/vuln/377872/cti
- https://pypi.org/project/pyod/3.6.2
- https://github.com/yzhao062/pyod/commit/16e6e3ad8921a4e18ccc8c2afe474db7d002c001
- https://github.com/yzhao062/pyod/releases/tag/v3.6.2
- https://github.com/yzhao062/pyod/
- https://pypi.org/project/pyod/3.6.2/