high7.0
CVE-2026-16584
Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security pol…
Impact
Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny or gate. When initialization of the security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect and are unaffected. To remediate this issue, users should upgrade to version 1.3.47.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | awslabs.aws-api-mcp-server | >= 0.2.13, < 1.3.47 | 1.3.47 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-29w2-fq35-v728
- https://github.com/awslabs/mcp/security/advisories/GHSA-29w2-fq35-v728
- https://nvd.nist.gov/vuln/detail/CVE-2026-16584
- https://github.com/awslabs/mcp/pull/4315
- https://github.com/awslabs/mcp/commit/ab1bbebc097d674c1cdd4bd75a8f313be18473bf
- https://aws.amazon.com/security/security-bulletins/2026-063-aws
- https://pypi.org/project/awslabs.aws-api-mcp-server/1.3.47
- https://aws.amazon.com/security/security-bulletins/2026-063-aws/
- https://pypi.org/project/awslabs.aws-api-mcp-server/1.3.47/