NetSight
medium6.1

CVE-2026-17596

Nexus Repository 3 was found to be vulnerable to stored cross-site scripting (XSS).

Impact

Nexus Repository 3 was found to be vulnerable to stored cross-site scripting (XSS). A user with the nexus:blobstores:create or nexus:blobstores:update permission could set a blob store name containing malicious script content, which would later execute in the browser of another user viewing system health-check status. This issue has been fixed in version 3.95.0.

Affected products

VendorProductAffected versions
SonatypeNexus Repository Manager
from 3.16.0 before 3.95.0

Weakness classification

References