medium5.3
CVE-2026-19113
Consul Community Edition and Consul Enterprise 1.3.0 through 2.0.2 are vulnerable to an unauthenticated denial of service in several agent HTTP API endpoints.
Impact
Consul Community Edition and Consul Enterprise 1.3.0 through 2.0.2 are vulnerable to an unauthenticated denial of service in several agent HTTP API endpoints. A remote caller could cause the agent to consume substantial memory before the request was rejected. This vulnerability, CVE-2026-19113, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.
Affected products
| Product | Affected versions |
|---|---|
| Consul Community Edition And Consul Enterprise 1.3.0 | through 2.0.2 |
Versions were read from the advisory text. No structured product data has been published for this record yet.