medium5.4
CVE-2026-23643
CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
Impact
### Impact The `PaginatorHelper::limitControl()` method has a cross-site-scripting vulnerability via query string parameter manipulation. ### Patches This issue has been fixed in 5.2.12 and 5.3.1 ### Workarounds If you are unable to upgrade, you should avoid using `Paginator::limitControl()` until you can upgrade.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | cakephp/cakephp | >= 5.2.10, < 5.2.12 | 5.2.12 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Cakephp | Cakephp | from 5.2.10 before 5.2.12 Version 5.3.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://bakery.cakephp.org/2026/01/14/cakephp_5212.html
- https://github.com/cakephp/cakephp/commit/c842e7f45d85696e6527d8991dd72f525ced955f
- https://github.com/cakephp/cakephp/issues/19172
- https://github.com/cakephp/cakephp/releases/tag/5.2.12
- https://github.com/cakephp/cakephp/releases/tag/5.3.1
- https://github.com/cakephp/cakephp/security/advisories/GHSA-qh8m-9qxx-53m5
- https://github.com/advisories/GHSA-qh8m-9qxx-53m5
- https://nvd.nist.gov/vuln/detail/CVE-2026-23643