critical8.7
CVE-2026-23891
Decidim has a cross-site scripting (XSS) in user name
Impact
Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | decidim-core | >= 0.31.0.rc1, < 0.31.0 | 0.31.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Decidim | Decidim | before 0.30.5 from 0.31.0 before 0.31.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-fc46-r95f-hq7g
- https://github.com/decidim/decidim/security/advisories/GHSA-fc46-r95f-hq7g
- https://github.com/decidim/decidim/releases/tag/v0.30.5
- https://github.com/decidim/decidim/releases/tag/v0.31.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-23891
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-core/CVE-2026-23891.yml