NetSight
high8.1

CVE-2026-23902

Incorrect Authorization vulnerability in Apache DolphinScheduler allows authenticated users with system login permissions to use tenants that are not defined o…

Impact

Incorrect Authorization vulnerability in Apache DolphinScheduler allows authenticated users with system login permissions to use tenants that are not defined on the platform during workflow execution. This issue affects Apache DolphinScheduler versions prior to 3.4.1.  Users are recommended to upgrade to version 3.4.1, which fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.dolphinscheduler:dolphinscheduler< 3.4.13.4.1

Affected products

VendorProductAffected versions
ApacheDolphinscheduler
before 3.4.1

Weakness classification

References