NetSight
high7.1

CVE-2026-23984

Apache Superset: Read-Only Bypass via Improper Input Validation on PostgreSQL Connections

Impact

An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-superset< 6.0.06.0.0

Affected products

VendorProductAffected versions
ApacheSuperset
before 6.0.0

Weakness classification

References