NetSight
high8.7

CVE-2026-24308

Apache ZooKeeper has improper handling of configuration values

Impact

Improper handling of configuration values in ZKConfig in Apache ZooKeeper 3.8.5 and 3.9.4 on all platforms allows an attacker to expose sensitive information stored in client configuration in the client's logfile. Configuration values are exposed at INFO level logging rendering potential production systems affected by the issue. Users are recommended to upgrade to version 3.8.6 or 3.9.5 which fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.zookeeper:zookeeper>= 3.9.0, < 3.9.53.9.5

Affected products

VendorProductAffected versions
ApacheZookeeper
from 3.8.0 before 3.8.6
from 3.9.0 before 3.9.5

Weakness classification

References