NetSight
critical9.8

CVE-2026-24713

Apache IoTDB has an Improper Input Validation vulnerability

Impact

Improper Input Validation vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.iotdb:iotdb-core>= 1.0.0, < 1.3.71.3.7

Affected products

VendorProductAffected versions
ApacheIotdb
from 1.0.0 before 1.3.7
from 2.0.0 before 2.0.7

Weakness classification

References