low2.7
CVE-2026-24733
Apache Tomcat - Security constraint bypass with HTTP/0.9
Impact
Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.tomcat:tomcat-coyote | >= 11.0.0-M1, < 11.0.15 | 11.0.15 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Tomcat | from 9.0.1 before 9.0.113 from 10.1.1 before 10.1.50 from 11.0.1 before 11.0.15 Versions 9.0.0, 10.0.0, 11.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/6xk3t65qpn1myp618krtfotbjn1qt90f
- https://github.com/advisories/GHSA-qq5r-98hh-rxc9
- https://nvd.nist.gov/vuln/detail/CVE-2026-24733
- https://github.com/apache/tomcat/commit/2e2fa23f2635bbb819759576a2f2f5e64ecf7c5f
- https://github.com/apache/tomcat/commit/6c73d74ff281260d74c836370ff6b82f1da8048b
- https://github.com/apache/tomcat/commit/711b465cf22684a1acf0cb43501cdbbce9b6c5f4
- https://tomcat.apache.org/security-10.html
- https://tomcat.apache.org/security-11.html
- https://tomcat.apache.org/security-9.html