NetSight
high7.5

CVE-2026-24880

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension.

Impact

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat-coyote>= 7.0.0, < 9.0.1169.0.116
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 7.0.0, < 9.0.1169.0.116

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.0 before 9.0.116
from 10.1.0 before 10.1.53
from 11.0.0 before 11.0.20

Weakness classification

References