high7.2
CVE-2026-25700
Improper Restriction of Security Token Assignment vulnerability in Apache Answer.
Impact
Improper Restriction of Security Token Assignment vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. Previously issued administrative tokens were not invalidated after an administrator account was suspended, deleted, or deactivated, allowing continued access to administrative APIs until the token expired. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/apache/incubator-answer | <= 1.4.2-RC1 | 2.0.1 |
| go | github.com/apache/answer | <= 1.7.1 | 2.0.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Answer | before 2.0.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-4gw2-vg4x-7p29
- https://nvd.nist.gov/vuln/detail/CVE-2026-25700
- https://lists.apache.org/thread/ftw52mlxknjm29vo1mnqovj53z2kh96y
- http://www.openwall.com/lists/oss-security/2026/06/10/10
- https://github.com/apache/answer/releases/tag/v2.0.1