NetSight
high7.2

CVE-2026-25917

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code.

Impact

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow-core< 3.2.03.2.0

Affected products

VendorProductAffected versions
ApacheAirflow
before 3.2.0

Weakness classification

References