NetSight
medium6.5

CVE-2026-25957

Cube Core is vulnerable to Denial of Service (DoS) via crafted request

Impact

### **Impact** It is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. ### Affected Versions: `>= 1.1.17` ### Mitigation: Upgrade to a patched version: - 1.5.13 and later (regular release) - 1.4.2 (active [LTS release](https://cube.dev/docs/product/administration/distribution#long-term-support)) ### **References** The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.

Affected packages

EcosystemPackageAffectedFixed in
npm@cubejs-backend/server-core>= 1.1.17, < 1.4.21.4.2

Affected products

VendorProductAffected versions
CubeCube.Js
from 1.1.17 before 1.4.2
from 1.5.0 before 1.5.13

Weakness classification

References